HVAC help!

Ericb

Founding Member
Founding Member
Joined
May 19, 2015
Posts
3,201
Likes
85
Points
288
Location
Bismarck
So my damn A/c went out today. It trips the breaker immediately, even before the compressor tries to start. Even with the system turned off at the thermostat. 2 months ago I replaced the contacts and the capacitor. If I disconnect the power to the compressor the fan will run but not at normal speed. I checked resistance to the compressor and it shows 10 plus ohms on each wire combo. I don't think it's the breaker in the house as its tripped the main breaker aswell a couple times. Any other tests I could do before I get someone out here tomorrow?
I have a feeling it's the compressor shorting but I'm in denial.
 


3Roosters

Founding Member
Founding Member
Joined
Jul 21, 2015
Posts
4,736
Likes
739
Points
343
Location
Devils Lake
I have central air in my older house. It has fuses. When my central air has gone out in years past, the fix was to replace the fuses. Not sure if that is your issue or not. Just giving you an idea if you have fuses.
 


Ericb

Founding Member
Founding Member
Thread starter
Joined
May 19, 2015
Posts
3,201
Likes
85
Points
288
Location
Bismarck
Yes, the run wire is sthorting in the compressor.

Thanks anyway!
 

Recent Posts

Friends of NDA

Top Posters of the Month

  • This month: 255
  • This month: 216
  • This month: 112
  • This month: 102
  • This month: 100
  • This month: 87
  • This month: 84
  • This month: 72
  • This month: 72
  • This month: 71
Top Bottom